Close

4WD-Robot Car Kit Arduino UNO – ovládání

Úvodní stránka Fórum Vaše projekty Arduino 4WD-Robot Car Kit Arduino UNO – ovládání

  • Toto téma obsahuje celkem 0 odpovědí. Do diskuze (1 diskutující) se naposledy zapojil uživatel Rynler a poslední změna proběhla před 5 roky a 2 měsíci.
Aktuálně je na stránce zobrazen 1 příspěvek (celkem z 1)
  • Autor
    Příspěvky
  • #10907
    Rynler
    Účastník

    Ahoj,
    prosím zkušenější o radu – pustil jsem se do stavby robota viz.:
    http://www.ebay.de/itm/162302756306?ul_noapp=true
    Zatím jsem pracoval jen s jednoduchými projekty, takto komplexní je můj první. Nedaří se mi robota ovládat IR a Bluetoth. Robot nereaguje na povely tak, jak má. IR – ovládací kříž tlačítek jakoby byl pootočen o 90st., tj. na tlačítko vpřed jede doprava, tlačítko vpravo jede zpátky atd… Při zmáčknutí tlačítka směru navíc jen „popojede“ a hned se zaství, další pohyb provede až po opětovném zmáčknutí tlačítka. Podle návodu má jet plynule. Obdobně Bluetoth – na povely reaguje víceméně chaoticky, nenašel jsem žádnou pravidelnost.
    Chybu v zapojení můžu myslím vyloučit, vše kontrolováno a zapojeno několikrát. Použil jsem i různé desky UNO R3, stejný výsledek. Trochu mě ale překvapilo, že ač jsou motorky zapojeny paralelně, někdy se otáčel na stejné straně jen jeden, v zápětí oba (slabé přívodní vodiče?). Celé mi to ale směřuje k chybě v programu, nebo knihovně. Má někdo typ co zkontrolovat, nebo jak postupovat dál?
    Dík za info, Rynler

Aktuálně je na stránce zobrazen 1 příspěvek (celkem z 1)
  • Pro reakci na toto téma se musíte přihlásit.