Close

arduino nano a naběhnutí programu

Úvodní stránka Fórum Hardware Arduino arduino nano a naběhnutí programu

  • Toto téma obsahuje celkem 3 odpovědi. Do diskuze (3 diskutující) se naposledy zapojil uživatel Dan a poslední změna proběhla před 7 roky a 1 měsícem.
Aktuálně jsou na stránce zobrazeny 4 příspěvky - 1. až 4. (celkem z 4)
  • Autor
    Příspěvky
  • #4098
    dejwak
    Účastník

    Dobrý den,
    jsem začátečník s arduinem (oblíbený uvod) a mám dotaz ohledně nabíhání programu a inicializace výstupů.
    Děje se mi, že po připojení k napájení mi začnou samovolně blikat ledky a protáčet 5v modelářské servo. Tento chaos a trvá tak 4 vteřiny a pak funguje správně. Zajímá mne jestli je to normální a nebo chyba v programu. Zkoušel jsem strejdu googla, ale asi jsem do něj zadával špatná hesla k vyhledání a nijak mi nepomohl a v okolí někoho kdo dělá s arduinem nemám, tak to zkouším tady a budu rád za odpovědi.

    #4099
    Zbyšek Voda
    Správce

    Dobrý den,

    k jakým pinům máte LEDky a servo připojené?

    #4110
    dejwak
    Účastník

    Dobrý den,
    mám ledky k pinům 9 a 10, servo je připojené na pin 8. Zkoušel jsem to prohazovat a například na pinech 4 a 5 mi ani servo neblbne a ani ledky neblikají.

    #4759
    Dan
    Účastník

    Dobrý den, na piny 8-10 by standardní bootloader sahat neměl, zvláštní problém. Mi nic takového atmega328p nedělá. Můžete zveřejnit zdrojový kód, typ arduina a popsat způsob jeho připojení? Koneckonců by to mohlo být i příliš měkkým napájením, bez bližších podrobností ale víc nevím…

Aktuálně jsou na stránce zobrazeny 4 příspěvky - 1. až 4. (celkem z 4)
  • Pro reakci na toto téma se musíte přihlásit.