Close

Odpověď na: Nahrání bootloaderu do atmega328

Úvodní stránka Fórum Hardware Arduino Nahrání bootloaderu do atmega328 Odpověď na: Nahrání bootloaderu do atmega328

#13888
Profilový obrázekmarcino
Účastník

Potýkal jsem se stejným problémem a hledání po internetu bylo též bezvýsledné. Spíš jsem posbíral střípky z různých zdrojů. Zjistil jsem toto: Pokud chci použít Arduino jako ISP, tak není Arduino jako Arduino. Červený klon mi nefunguje i kdybych se zbláznil, avšak modrý klon mi funguje perfektně. Taky není IDE jako IDE. Nová verze mi nefunguje, avšak verze 1.6.9 funguje perfektně. Proč to tak je nevím. Stačí si stáhnout tuto starší verzi z oficiálních stránek.
Pokud to chcete zkusit, je lépe si založit v dokumentech novou složku Arduino s prázdnými podadresáři hardware a libraries. Tu stávající složku Arduina v dokumentech dočasně přejmenujte, ať se to nemíchá. Pak to zase vrátíte nazpět jak to bylo.
Inspirující pro mě bylo toto video: https://www.youtube.com/watch?v=sSfmDcAwR6k
Říkal jsem si, že když to fungovalo jemu, musí to fungovat i mě. Tak jsem to zopakoval přesně jako on a to i včetně verze IDE, kterou používal.
Domnívám se, že tato rada asi nebude fungovat všem, ale možná někomu pomůže. Existuje mnoho faktorů, které v tom všem hraje roli.