Close

problem s arduinem (micro)

Úvodní stránka Fórum Hardware Arduino problem s arduinem (micro)

  • Toto téma obsahuje celkem 8 odpovědí. Do diskuze (2 diskutující) se naposledy zapojil uživatel mirec73 a poslední změna proběhla před 6 roky a 12 měsíci.
Aktuálně je na stránce zobrazeno 9 příspěvků - 1. až 9. (celkem z 9)
  • Autor
    Příspěvky
  • #3250
    mirec73
    Účastník

    zdravim,

    Chtel bych poprosit o pomoc s mim arduinem (druh – Arduino micro), problem je taky ze muj notebook arduino nevidí (tohle Arduino micro mam us 2 mesice a fungovalo v pohode , ted ale nejde).
    Arduino se neukazuje na zadnem z COM portu. Kdyz ho pripojim tak se rozsviti modra dioda zespodu. Kdyz stlacim tlacilo RESET zacne blikat dioda nazeleno, pokad blika arduino je pro PC viditelne, vidim ho aj na nejakem COM porte. Ale kdyz zelena dioda bootloaderu doblika (cca 8 sec) Arduino je zase neviditelné pro PC ,zmizi ze sveho com portu. Skousel sem pripojit na muj notebook aj Arduino mega ale to slo v pohode. Problem bude pravdepodobne nekde v tom arduine micro ale nevim jaky .

    za pomoc dekuju

    #3251
    Aleš
    Účastník

    Bootloader je aktivní těch 8s. Viz http://www.arduino.cc/en/Main/arduinoBoardMicro Takže je potřeba během 8s spustit upload programu. Potom se rozeběhne program nahraný v micro, a port se přepne z režimu bootloader (emulace COM portu) do režimu USB (slave) zařízení.

    #3252
    mirec73
    Účastník

    dekuju moc funguje to timhle spusobem uplne v pohode
    a jeste jedna otazka trochu pomimo je mozne odpali sensor BH1750 staticku elektrinu nebo vymenenim kontaktu ? (gnd na +5V a +5V na gnd) pac my bud odesel nebo nevim . Kdyz spustim skenovani zarizeni na SDA/SCL tak se to vzdy sekne a jakmile sensor odpojim pokracuje vpohode.
    dekuju

    #3296
    Aleš
    Účastník

    Najdi součástku označenou 662K (stabilizátor z 5V na 3,3V, http://www.mikrocontroller.net/attachment/193855/LM6206N3.pdf) a změř, jestli je na pinu 2 (OUT) 3,3V Nic jiného asi odejít nemohlo.

    #3351
    mirec73
    Účastník

    ano , ten stabilizátor vážne odešel , tak sem ho odstranil a napojil na 3,3V ale nefunguje porad

    #3352
    Aleš
    Účastník

    Podle schématu může být ještě problém s PullUp odporem R4 4K7 na SDA_O. Ten je připojený na +5V. Teď tam máš místo 5V jenom 3,3V, a to nemusí Arduinu stačit, aby signál správně vyhodnotil. Asi by to chtělo stabilizátor vyměnit 🙁

    #3355
    mirec73
    Účastník

    no to by asi bylo nejlehci kupit novy stabilizator ale netusim kde ho sehnat … a kvuli 1 stabilizatoru sa mi nechce platit postovne 😀 ale co se tice te schemy asi bude spatna , pac ja tam mam jenom 4 odpory , zadny mosfet a ani diodu + ani to zapojeni mi nejak nesedi , ale zagooglil sem a nasel sem schemu ktera presne sedi aj poctami sucastek aj zapojenim (nektere hodnoty sucastek su jine napr. R na addr je 1k ne 4k7 ) … ale nic tam nepotrebuje tech 5V , secko je jenom na 3,3V

    GY302Schematic

    #3357
    Aleš
    Účastník

    Potom by asi bylo lepší koupit nový celý modul. Na eBay vyjde asi na 40Kč včetně poštovného 🙂
    http://goo.gl/9xGYpw
    Teď si uvědomuju, že ho tady mám někde taky. Chtěl jsem ho montovat do meteostanice 🙂

    #3360
    mirec73
    Účastník

    jop uz se stalo 😀 na http://www.banggood.com ho maju docela dost levny a maju tam hodne doplnku k arduinu tak sem ho objednal aj s dalsima komponentama kere sa budu urcite hodit 😀

    dekuju ti za pomoc 😀

Aktuálně je na stránce zobrazeno 9 příspěvků - 1. až 9. (celkem z 9)
  • Pro reakci na toto téma se musíte přihlásit.