Close

WIFI XBEE WEE

Úvodní stránka Fórum Hardware Arduino WIFI XBEE WEE

Aktuálně jsou na stránce zobrazeny 3 příspěvky - 1. až 3. (celkem z 3)
  • Autor
    Příspěvky
  • #12012
    Profilový obrázekZdenekRSA
    Účastník

    Dobry den,
    Pouzivam Arduino Mega 2560 with Mega Sensor Shield.
    Kdyz pripojim wifi Xbee Wee dostanu zpravu:
    avrdude: stk500v2_ReceiveMessage(): timeout

    Pri pokusu najit jiny port dostanu zpravu:
    error: espcomm_upload_mem failed

    Pokud odpojim Wee vse funguje bez problemu.
    Dekuji za kazdou odpoved.
    Zdenek

    #12013
    Zbyšek VodaZbyšek Voda
    Správce

    Dobrý den,
    nejsem si teď úplně jistý, ale tento modul komunikuje přes sériovou linku, že?

    On je problém v tom, že nahrávání programu do Arduina probíhá také přes sériovou linku a když je na ní připojeno ještě něco dalšího, bývá problém s tím, že připojená věc ruší komunikaci na lince.

    U desky Arduino Mega máte výhodu, že má vícero hardwarových sériových linek (Označené RX0, TX0, RX1, TX1, …). Programování Arduina probíhá přes RX0 a TX0. Probém můžete vyřešit tím, že WiFi Modul připojíte na jinou sériovou linku, než RX0 a TX0. Pak musíte také upravit program, ale to by mělo být jednoduché :)

    #12014
    Profilový obrázekZdenekRSA
    Účastník

    Dobry den,
    dekuji za Vasi odpoved. Ja jsem v tomto oboru zacatecnik, ale myslim, ze mi vase odpoved hodne pomohla. Budu si s tim hrat podle vaseho navodu a dam Vam vedet.
    Jeste jednou dekuji.

Aktuálně jsou na stránce zobrazeny 3 příspěvky - 1. až 3. (celkem z 3)
  • Pro reakci na toto téma se musíte přihlásit.